Home Foren spacedesk Discussions UWP Viewer 0.0.23.0 comes out of fullscreen on resolution changes and sleep

Ansicht von 4 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Autor
    Beiträge
  • #6646
    shodan
    Teilnehmer

    Currently using Spacedesk viewer X86/UWP version 0.0.23.0
    Works great, but it often switches from fullscreen to maximized windows upon various screen related events.

    In particular, if other screens change resolution or if the computer goes to sleep.

    This does not happen all the time. I would say once out of 3 or 4 times.

    NOTE : This might not have anything to do with it but, I run two instances of spacedesk viewer on the same windows PC each on their own screen.

    Full setup is as follow

    Spacedesk server is running on windows PC with one monitor attached (1920×1080)

    I have four screens in total
    2x 1680×1050 screens running on android on a ARM based SBC
    and 2x 1680×1050 more screens running off another windows x86 PC running uwp spacedesk viewer

    The android viewer does not ever have the „coming out of fullscreen“ problem

    A few more observations

    When the server PC goes to sleep, the android screens remains turned on and display bouncing disconned message
    The windows PC running viewer, eventually goes to sleep, but does not wake up when the server PC wakes up.
    However, manually waking up the viewer PC, it will reconnect, the viewers are still in the right location, just sometimes not fullscreen anymore.

    If the windows viewer PC is reset, I have autologin enabled, however I have not found out how to automatically start two instances of the spacedesk viewer and each put them in fullscreen and each in their proper screen. But over all it works great and is very usable

    Here is a picture of my setup

    #6654
    spacedesk Lea
    Verwalter

    Hi @shodan,

    Thank you very much for the feedback.

    1. Coming out of fullscreen
    We will try to reproduce it, but so far it’s not yet happening on our side. Maybe keeping the client monitor active to prevent monitor sleep can already help avoid this, please check #2.

    2. To keep the client monitor active while server is on PC sleep, just activate it in the spacedesk UWP viewer Settings -> Display -> Keep display on.

    3. To start spacedek UWP Viewer automatically during Windows Start-up, we suggest the following steps:
    – run „shell:appsFolder“ then find spacedesk VIEWER
    – right-click the spacedesk VIEWER -> Create shortcut
    – the shortcut file will be created on the Desktop
    – run „shell:startup“, then copy/move the „spacedesk VIEWER – Shortcut“ file from Desktop to the Startup folder.
    (just copy-paste another shortcut file with different name so that it will start two UWP viewer instance upon start up)
    PS: As for the position of each viewer instance, we don’t know if it’s possible to specify the position for each instance, maybe you have to create a simple program for it.

    #6714
    shodan
    Teilnehmer

    Thanks for the reply

    I notice my photo did not go through due to the 512kb image limit
    I have reduced the image quality further so you can have an idea of my setup.

    So, as per the second screenshot, you can see my screen layout

    Screen 1 is physically attached to my spacedesk server PC

    Screen 2 and 5 are android devices with hdmi output running spacedesk viewer for android, these work no problem, except they do not go to sleep when the server PC does, but that is only minor annoyance (it does say „power save mode“ but the screen does not sleep)

    Screen 3 and 4 are both connected to another windows PC, they are screen 1 and 2 on that PC.

    So I have two instances of spacedesk viewer running on that PC.
    This might be the reason why they come out of fullscreen occasionnally ?

    When I have to restart my entire system, I have to start two copies of spacedesk viewer, that is the problem.

    Are there command line parameters for starting spacedeskviewer ?
    The problem is that when I start two copies of spacedeskviewer, they both start on the same (screen 1) and I have to move them manually.

    I would like a command line parameter when I can say client id {AAAAA-BBBBBBBB} start fullscreen on screen 1 and cliend id {CCCCCCCCC-DDDDDDDDD} start on screen 2

    Also please note that the client come out of fullscreen only on the windows PC running spacedeskviewer, this does not happen on the android devices.

    And it is not only going to sleep (which I do not want to disable, I want everything to go to sleep when I am not using it) that causes the spacedesk client to come out of fullscreen but changes in resolution of Screen 1 on the spacedesk server (for instance when an application runs in fullscreen on screen 1, it will switch through other resolution and cause all the screens to flash a little, this is when the out of fullscreen happens)

    This is only a little annoying, because I need to keep an extra mouse handy at all times for the viewer PC.

    Ideally I would have 4 android devices running the four screens but they are currently out of stock 🙁
    Other than that pretty happy with everything to do with spacedesk

    I do have one other recommendation to make, currently spacedesk client only accept a IP address, but I would like to use a hostname my PC is called hadron.lan, its IP address changes occasionally but it is always reachable by the hostname „hadron.lan“ so access via hostname instead of IP address would be more rliable

    Attachments:
    You must be logged in to view attached files.
    #6750
    spacedesk Lea
    Verwalter

    Hi @shodan,

    1. Maybe the coming out of full screen is still a bug in our Windows Viewer app which we cannot fix immediately.
    This will take time to analyze and fix.

    2. Command line parameter
    Currently, spacedesk Windows 10 and/or 7 Viewer do not have command line to start up.
    You can create a simple program that can auto-run and assign the position of each instances or maybe search for a third party application tool that can do this.

    3. Connection via hostname
    It should work, by setting it in the UWP Viewer settings -> Connection -> Start-up connect -> host name, type your host name.
    Then on the next time you run the UWP viewer app, it will automatically connect to that host name.

Ansicht von 4 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.