Home Forums spacedesk Discussions Mouse freeze on primary device

Viewing 12 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #7138
    MdA
    Participant

    After installing SPACEDESK DRIVER SOFTWARE for Windows PRIMARY PC (server) on a Windows 10 PC and then connecting from the second device (fire tv stick), the mouse will be disabled on the Windows PC. But I want to use the TV only as a 2nd screen (pure display without inputs). How can I prevent the mouse from being disabled on the Windows PC?

    Version PC: Beta RC v1.0.37
    Version Fire TV Stick: Android App v0.9.95

    Windows Firewall Rule allow for spacedesk
    All devices are in the same network (192.168.xxx.xxx)

    #7145
    spacedesk Lea
    Keymaster

    Hi @mda,
    Thank you very much for the feedback.
    We have checked this issue and so far we have never experienced a mouse freeze on primary machine upon spacedesk connect.

    Maybe disabling all remote input on your viewer app might help.
    Please try to disable it in your Android Viewer app settings -> Input devices, just uncheck the touchscreen and pen input box before connecting.
    Then let us know your result.

    #7151
    MdA
    Participant

    OK, I have disabled all input devices. The mouse freezes as soon as I connect via the Android app. After I manually disconnect, the mouse becomes usable again.

    #7155
    spacedesk Lea
    Keymaster

    Hi @mda,
    To further analyze the issue, could you please send us the diagnostic logs for this issue.
    Please follow the steps below:
    – open spacedesk Driver Console in your primary machine
    – go to Diagnostics, if DebugView is Unavailable, download it first
    – switch Diagnostic Collection ON
    – connect the viewer app to reproduce the mouse freeze, then disconnect after a few seconds (~10sec)
    – switch Diagnostic Collection OFF
    – click Save All Information
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #7854
    GarrettPatton
    Participant

    You can connect your TV and PC via HDMI.

    #8740
    Nirbhay
    Participant

    Hi Spacedesk Lea,
    I am also facing the same issue as @MdA. As soon as I connect with my mobile phone with the computer the mouse stops working. After disconnecting it works fine.
    Here is my configuration.

    Windows 10 Home Version: 10.0.19044 Build 19044
    Spacedesk Driver Console version: BETA RC Version 1.0.46

    I have followed your above instructions of generating diagnostic log and have attached the same.

    Please provide some solution for this.

    Attachments:
    You must be logged in to view attached files.
    #8757
    spacedesk Lea
    Keymaster

    Hi @nirbhay,
    Thanks for sending the diagnostic logs.
    Could you please try to disable the Nvidia ShadowPlay/In-game overlay/screen recording (via Nvidia GeForce Experience window) on your primary machine?
    Then please check if the mouse still freezes upon spacedesk connect.

    #8761
    Nirbhay
    Participant

    Hi Spacedesk Lea,
    Can you give instructions of how to disable Nvidia ShadowPlay/In-game overlay/screen recording (via Nvidia GeForce Experience window)

    #8762
    Nirbhay
    Participant

    Hi Spacedesk Lea,

    I have disabled the In-game overlay of Nvidia Geforce Experience and have attached a screenshot regarding the same. Also I had also generated a new log after disabling the overlay. Please find both attachments below.

    Please provide some solution for this.

    Attachments:
    You must be logged in to view attached files.
    #8779
    spacedesk Lea
    Keymaster

    Did you try to restart after disabling the in-game overlay?

    #8782
    Nirbhay
    Participant

    I had got my problem there is setting know as turn off the trackpad as soon as a mouse is connected. As secondary screen was a touch device it treated the secondary device connected to a mouse. As soon I toggled that setting to off Spacedesk started to work as intended.

    #8783
    spacedesk Lea
    Keymaster

    I see.. thanks for the info. We are glad that spacedesk is now working on your side.

Viewing 12 posts - 1 through 11 (of 11 total)
  • The topic ‘Mouse freeze on primary device’ is closed to new replies.