Home Forums spacedesk Discussions Server problems

Viewing 9 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8152
    Yarni
    Participant

    I am experiencing 2 problems.

    The first problem is that with the latest update (1.0.42), the on-off button for starting the spacedesk server only works once: I can activate the server once and then turn it off and then it will stay off despite sliding the spacedesk status button to ‘ON’. To get around this I have to open taskmanager and stop the spacedesk service. I’ve tried uninstalling and reinstalling (64-bit windows 10) with the same results, and repairing crashes at the last step.

    The second problem is that my virtual display (android tablet) will be disconnected after some time (ca 10 minutes), displaying ‘connected – display OFF’, and I’m pretty sure the problem is connected to the spacedesk server on the primary machine, as restarting it lets the display connect again.

    • This topic was modified 6 months ago by Yarni.
    #8159
    spacedesk Lea
    Keymaster

    Hi @yarni,

    Thank you very much for reporting these issues.

    1. For the ON-OFF button, could you please try to run services.msc, then find spacedeskService and try to stop-start it (maybe a few times) and check if it’s also hanging.

    2. For the disconnection problem, could you please send us the diagnostic logs.
    Please follow the steps below:
    – Open spacedesk Console window -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your viewer app and reproduce the disconnect issue
    – switch Diagnostic Collection OFF
    – click Save All Information button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    By the way, can you also tell us your android tablet’s android version? Is it connected over WiFi network/UBS tethering/WiFi Hotspot?

    #8172
    Yarni
    Participant

    Hi Lea!

    1. I found spacedeskService in services.msc but it was stuck in the process of stopping and could I could not start or stop it.

    2. The connection was more stable yesterday and I had a hard time catching the issue (it did happen still, but with hours between) but today the display is turned off after a few minutes. I’ve attached the requested zip file in this post.

    The android version is 7.1.1 and I am using reverse usb tethering for the internet connection.

    #8174
    Yarni
    Participant

    Sorry is the attachment available publicly? Could you delete it once you’ve downloaded it please?

    #8180
    spacedesk Lea
    Keymaster

    Hi @yarni,

    Thank you very much for sending the diagnostic logs.
    Based on the logs, you have Nvidia ShadowPlay/In-game Overlay enabled.
    Please disable it in Nvidia GeForce Experience settings (then restart the spacedeksService) before connecting a spacedesk viewer and check if you still have the issue.

    #8189
    Yarni
    Participant

    Hi Lea!

    I turned off shadowplay and restarted, but both problems persisted unfortunately. For the spacedesk services not stopping, I figured out that this only happens when the virtual screen looses its connection to the server. I’m attaching new diagnostic logs to this reply.

    • This reply was modified 6 months ago by Yarni.
    #8192
    Yarni
    Participant

    I’m starting to suspect that perhaps the fault lies with my usb tethering loosing connection as I am using gnirehtet and I’m not sure how reliable it is.

    #8203
    spacedesk Lea
    Keymaster

    Hi @yarni,
    Thank you very much for the feedback.
    We are currently analyzing the logs and trying to reproduce the issue on our side, but so far it’s not successful.
    We will get back to you as soon as we have news or new version for you to test.

    #8209
    Yarni
    Participant

    Thanks and best of luck! Could you delete the latest logs I attached as well? Appreciate it

Viewing 9 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.