Home Forums spacedesk Discussions Wrong rotation for Android 10 after latest upgrade

Viewing 7 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7639
    kordula2@gmail.com
    Participant

    Thank for a VERY good product!
    Way better than anything i used before…

    I use it to mirror my windows 11 screen to an android tablet (latest Spacedesk version and driver on both).
    The tablet is an Lenovo TB-X505F running android 10.
    It can not be upgraded to android 11, sadly.

    It worked perfect until i 5 days ago download latest version from Google Play, then it rotated the mirrored screen in the moment it connect to it.
    I turned on and off rotation in tablet and spacedesk, with restarts inbetween, but the problem is still there.
    However:
    If i connect another tablet, Galaxy Tab A7, with android 11 first.
    Then that works fine with spacedesk.
    When i then try to connect my Lenovo tablet, it connects with correct rotation, but it display the background only.
    When i then disconnect the Galaxy tablet, the mirrored image on the Lenovo tablet rotate,
    but display the complete PC screen.

    I do not need two duplicates of the windows monitor, this was just for debug purposes.

    Hope you can solve this, as i would like to use the android 10 tablet again.

    best regards
    Hans

    Attachments:
    You must be logged in to view attached files.
    #7649
    spacedesk Lea
    Keymaster

    Hi @kordula2gmail-com,

    Aside from the Auto-rotation settings in the Viewer app, did you also enable the auto-rotation settings on your tablet’s settings?

    For further analysis, please send us the diagnostic logs:
    – open spacedesk Driver Console app -> Diagnostics
    – if DebugView is “Unavailable”, download it first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – connect your Viewer app and reproduce the rotation issue
    – switch Diagnostic Collection OFF
    – click “Save All Information” button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #7654
    kordula2@gmail.com
    Participant

    Here is the diagnostic dump

    Attachments:
    You must be logged in to view attached files.
    #7673
    spacedesk Lea
    Keymaster

    Hi @kordula2gmail-com,
    Thanks for sending the diagnostic logs.
    It seems that the diagnostic logs are incomplete.
    Did you do these steps before clicking the “Save All Information” button?
    – if DebugView is “Unavailable”, download it first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – connect your Viewer app and reproduce the rotation issue
    – switch Diagnostic Collection OFF

    #7681
    kordula2@gmail.com
    Participant

    hope it is ok now!

    Attachments:
    You must be logged in to view attached files.
    #7705
    spacedesk Lea
    Keymaster

    Hi @kordula2gmail-com,
    Thanks for sending the diagnostic logs.
    Could you please try the following:
    – open spacedesk Driver Console -> Control -> Clear Windows Display Settings
    – connect your Lenovo tablet (expect to see the tablet as Extension mode)
    – make sure that the position/orientation of the tablet is in Landscape mode
    – open the Display settings window and switch to Mirror/Duplicate mode or just press Windows Logo + P key then select “Duplicate”

    #7829
    kordula2@gmail.com
    Participant

    Thanks!
    I cleared windows settings
    And then it was fixed!

    Again thanks for a VERY good product.

    Have a nice summer

    Hans

Viewing 7 posts - 1 through 6 (of 6 total)
  • The topic ‘Wrong rotation for Android 10 after latest upgrade’ is closed to new replies.