Home Forums spacedesk Discussions You need an older version

Viewing 5 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4397
    Leopq
    Participant

    I’m trying to install spacedesk, but it says “An earlier version of spacedesk is already installed. Continue and Update spacedesk windows driver?” And when I press NEXT it says I need “spacedesk_driver_Win_10_64_v0989_BETA.msi” ..
    I don’t have that file, so I need help.

    Attachments:
    You must be logged in to view attached files.
    #4410
    spacedesk Lea
    Keymaster

    Hi @leopq,
    The v0989 installer msi has an uninstall bug, please try to uninstall the older version of spacedesk manually.
    Please check the Manual Uninstall (Troubleshooting Only) steps in the user manual https://www.spacedesk.net/user-manual/.

    #4422
    Leopq
    Participant

    I did everything that the manual said and it did not work, but there were drivers that were not in my pc and the keys “HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ spacedeskKtmInputMouse” and “HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ spacedeskDriverBus” were not deleted.

    Attachments:
    You must be logged in to view attached files.
    #4430
    spacedesk Lea
    Keymaster

    Hi @leopq,
    Could you please run devmgmt.msc, click View tab -> Show hidden devices and View by Connections.
    Then check if you find any spacedesk devices, please right-click uninstall it, especially spacedesk virtual HID device.
    If there’s any devices underneath it, please delete them first before the spacedesk virtual HID device.

    If the above suggestion does not help, please go to https://support.microsoft.com/en-us/topic/fix-problems-that-block-programs-from-being-installed-or-removed-cca7d1b6-65a9-3d98-426b-e9f927e1eb4d and download the troubleshooter.
    If spacedesk is not on the program list, just select “Not Listed” then paste the product code of v0989 MSI below:
    spacedesk_driver_Win_10_64_v0989_BETA.msi: {5BDDEED1-A796-4811-BD50-811C680FF13B}

    #4473
    Leopq
    Participant

    thanks for the support, I was able to uninstall the last version.

Viewing 5 posts - 1 through 4 (of 4 total)
  • The topic ‘You need an older version’ is closed to new replies.