Home 论坛 spacedesk Discussions Can’t Install or Upgrade SpaceDesk to Latest Version

正在查看 6 个帖子:1-5 (共 5 个帖子)
  • 作者
  • #9728

    A long time ago I installed Spacedesk (v.0989) on one of my laptops (computer #1 – Dell Inspiron 2014) and it was super laggy.

    Flash forward about a year and a half I installed the latest (v.1050 I think, nov 4th 2022) version on a second laptop (computer #2 – Dell Latitude 2010) and it was much improved.

    I went back to computer #1 and not seeing an uninstall in the start menu I tried it through Windows…big mistake.

    Basically I didn’t know I could uninstall by rerunning the .msi.

    The uninstall basically hung about 1/10th of the way in – I left it running for about an hour.

    I then tried to remove it manually using the instructions on the site.

    Still no dice.
    I then tried the Microsoft Fix and that also hung.
    So, I can’t uninstall or upgrade.

    Can anyone steer me in the right direction as to how to uninstall Spacedesk?

    I have an ancient tablet that works really well on computer #2 and I want to put it on #1.

    spacedesk Lea

    Hi @djfrodo,

    For analysis, could you please send us the following file in your Computer #1?
    – run dxdiag.exe on your primary machine, click “Save all information” and send us the output file
    – spacedeskSetup.log file located in C:\Users\Public
    – setupapi.dev.log file located in C:\Windows\INF

    Please save all requested files in one folder, then right-click -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.


    Here you go


    Let’s try this again…

    spacedesk Lea

    Hi @djfrodo,

    Thanks for sending the setupapi.dev.log file.
    Based on the setup logs, the uninstallation for spacedesk virtual HID device is hanging.
    This is a known issue in that old installer version which we already fixed in the most recent version.
    To solve this on your machine, please manually uninstall the spacedesk virtual HID device in Device Manager.

    – open Device Manager by running “devmgmt.msc”
    – click View tab -> Devices by connection
    – scroll down and find spacedesk virtual HID Device
    – expand first the spacedesk virtual HID Device and right-click “Uninstall device” each devices underneath it
    – then right-click “Uninstall device” the spacedesk virtual HID Device

    Then try again to update with the latest spacedesk installer.


    Thanks so much.

    For anyone who comes after me with this problem this worked and I now have an OG Galaxy Tab 10.1 as a second monitor on an old (potato) Dell.

    It’s a little laggy but certainly within reason.

    Thanks again

正在查看 6 个帖子:1-5 (共 5 个帖子)
  • 话题“Can’t Install or Upgrade SpaceDesk to Latest Version”已关闭,不接受新回复。