Home Forums spacedesk Discussions Bug: Flipped Display – wrong color, laggy mouse

Viewing 6 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11512
    Yikes2000
    Participant

    Server Beta RC v1.0.50 on Windows 10

    When “Flipped Display” is activated, the mouse is laggy on the flipped image, and the color is wrong (tried all SubSampling options).

    Attachments:
    You must be logged in to view attached files.
    #11514
    Yikes2000
    Participant

    Test image showing the wrong color.

    Attachments:
    You must be logged in to view attached files.
    #11518

    Hi @Yikes2000,

    In order for us to further investigate this problem, please send us a copy of your diagnostic logs by following the steps below:

    – Open spacedesk Driver Console -> Diagnostics
    – if Debug View is not available, please click the download button first
    – switch Diagnostic Collection ON (make sure to click Yes in the User Account Control box to proceed)
    – try to connect your viewer app and reproduce the issue
    – switch Diagnostic Collection OFF
    – click Save All Information button
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #11525
    Yikes2000
    Participant

    Here is my diagnostic logs. Thanks for looking into this!

    Attachments:
    You must be logged in to view attached files.
    #11548

    Hi @Yikes2000,

    Please try the following workaround:

    1. Update both of your NVIDIA Geforce RTX 3080 graphic’s Game Ready Driver and Studio Driver from their official website, just input the details of your driver in the dropbox. (Geforce RTX 30 series, Windows 10 64bit)
    Link: https://www.nvidia.com/Download/index.aspx?lang=en-us
    note: if one of the drivers is not available, you can proceed to download what’s available from the choices

    2. Try to enable your HDR in windows settings. you can access this by going to windows settings > Display > Windows HD Color > enable ‘Stream HDR video’

    Then Please tell us the result in your next reply.

    #11679
    Yikes2000
    Participant

    1. Updated to latest Game Ready driver for Nvidia RTX 3080 (could only install one of them, “Game Ready” or “Studio” driver, not both).

    2. Only main monitor is HDR capable. Turning HDR to ON fixes the problem, but the main monitor becomes unusable — color calibration doesn’t work in HDR mode.

    Please note, turning off “Flipped Display” also fixes the problem when HDR is OFF. Something is inefficient and backward about the flip code, e.g. a pixel of 0x10101111 is flipped to 0x11110101 when it should remain the same while the pixel position is flipped with respect to the screen.

    • This reply was modified 2 weeks, 1 day ago by Yikes2000.
Viewing 6 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.