Home Forums spacedesk Discussions Cannot detect Server! Only on one of my devices

Viewing 4 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #9136
    woqq445721624
    Participant

    Hello,

    I have two devices to expand the screen of my laptop, one iPad and one iPhone. The iPad can detect the laptop and is able to connect to the laptop. My iPhone was able to connect once, but when I open the APP tho other day, it cannot detect the server anymore. By the way, HTML5 works properly on my iPhone, only the APP on my phone cannot work. Both devices and the laptop are in the same WiFi. Thank you for the help!

    #9138
    spacedesk Lea
    Keymaster

    Hi @woqq445721624,
    Could you please check on your iPhone’s settings -> Privacy -> Local Network, if spacedesk is on the list and enabled?

    #9145
    woqq445721624
    Participant

    Hi Lea,

    Yes, the spacedesk is on the list and enabled.

    #9152
    woqq445721624
    Participant

    Hi Lea,

    The issue is fixed.

    Although I don’t know why this happens, I can provide all the information I have to better state the issue and maybe it will help us address the problem.

    I used my laptop (i7-6700k plus NVIDIA P5200, CLEVO P770DMG) as the host machine, only one screen (LG 34′ Ultrawide 144Hz) was used, the internal screen from my laptop was disabled. Then, I used my iPad pro (I believe it is 2019 version) as the extension screen, which doesn’t have any problem from the beginning to the end. Then, I used my iPhone X as my second extension screen. At the beginning, it successfully conntected, but after I quitted the APP, and came into again, the APP in iPhone didn’t show any host machine. Even I used another laptop as the host machine, the iPhone didn’t show anything (neither first nor second laptop), while the iPad showed both host machines. However, when I used HTML5 to find the hose machine, it can succeed to connect in the Safari of the iPhone.

    Recently, I change the graphic card in the first laptop from P5200 to 970m, DELETE ALL GRAPHIC DRIVERS and REINSTALL THEM. The iPhone shows the host machine. During the duration from the failed time till now, I ONLY change the drivers. So, I think it is due to the graphic drivers. However, one thing doesn’t support this conclusion is that I also used another laptop (second host machine), but the APP on iPhone cannot find that neither. After I reinstall the driver in my first laptop, the second laptop magically shows in the APP on iPhone too.

    I don’t quite understand why the driver on first laptop can also affect the second laptop? Is there anything hooking some configuration file in iPhone and it affect the whole local network?

    By the way, thank you for making this convenient and great software.

Viewing 4 posts - 1 through 3 (of 3 total)
  • The topic ‘Cannot detect Server! Only on one of my devices’ is closed to new replies.