Home Forums spacedesk Discussions cannot find the right ip with 2 router in my network.

Viewing 9 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6872
    leungzw
    Participant

    Router1 IP :192.168.2.2, which is use for internet connecting and DHCP server.
    router2 IP:192.168.2.10, use as a gateway for some devices only, DHCP OFF.
    and running a server on PC with IP 192.168.2.x

    when i open the app on table, the app can only found the router2’s IP,
    even i input my laptop ip, also can’t working properly, with showing IP-validation only.

    anyone can help with this issue?

    Attachments:
    You must be logged in to view attached files.
    #6925
    spacedesk Lea
    Keymaster

    Hi @leungzw,
    For further analysis, could you please open the spacedesk Driver Console -> Diagnostics, then click Save All Information button.
    PS: Saving all information will take a few seconds, then please send us the whole folder which contains all the diagnostic logs collected.
    Please right-click the folder -> Send to -> Compressed (zipped) folder, then attach the *.zip file in your next reply.

    #6926
    leungzw
    Participant

    I zipped log files in attachment.

    Attachments:
    You must be logged in to view attached files.
    #6928
    spacedesk Lea
    Keymaster

    Hi @leungzw,
    Thank you very much for sending the diagnostic logs.
    Could you please check your (Router1’s) WiFi router’s network isolation if it’s active/enabled.
    This setting prevents direct communication between connected devices. The only solution for this is re-configuring the router.

    #6929
    leungzw
    Participant

    Network isolation is not activated on Router1.
    I can ping my pc 192.168.2.229 on my cellphone correctly.
    which port spacedesk use to transfer data? Is it related to firewall settings?

    Attachments:
    You must be logged in to view attached files.
    #6932
    leungzw
    Participant

    by the way, everything works well when I connect the PC to cellphone directly via WiFi-hotspot.

    So I am now try to figure out where’s the problem in local network.

    #6933
    spacedesk Lea
    Keymaster

    Hi @leungzw,

    spacedesk automatically configures the Windows Firewall to allow spacedeskService during installation, you can verify it via Control Panel\System and Security\Windows Defender Firewall\Allowed apps.

    Maybe you can also try to manually create an Inbound/Outbound rules in the Firewall settings for spacedeskService.
    spacedesk uses TCP port 28252.

    By the way, what is the current network profile on your primary machine? Public or Private?
    Are both WiFi network on primary machine and cellphone have the same network band/frequency (e.g. 2.4GHz or 5Ghz)?

    #7848
    leungzw
    Participant

    finally I found the problem was on the router2(IP:192.168.2.10) which is running a openwrt firmware.
    After I remove this openwrt router out of the network spacedesk works fine.
    maybe some openwrt feature is blocking some spacedesk traffic?

    #7856
    spacedesk Lea
    Keymaster

    Hi @leungzw,

    We are not familiar with openwrt so we are not sure if this is blocking spacedesk.
    Anyway, we are glad that it is now working on your side.
    In case you have other spacedesk related concern don’t hesitate to contact us.

Viewing 9 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.