Home 討論群 spacedesk Discussions Frequent tablet disconnect / reconnect – work-around

正在檢視 0 篇文章
  • 作者
    文章
  • #8304
    greengolem
    參與者

    First, a huge THANK YOU to the smart folks at datatronicsoft for making and releasing this very cool tool! I am using it daily to give myself more screen real estate, and it (mostly, see below) works like a charm. I’m really impressed with the refresh and depth available when using a local network and higher-end tablet – graphics are very smooth!

    THE SETUP:
    I have an Android tablet connected as a desktop extension using spacedesk, with the latest server-side driver software (v1.0.42) and latest Android app (v0.9.97) as of 6/17/2022. The desktop (Windows 11) has a wired connection to my lan/wan/wifi router, and the tablet (Samsung Galaxy Tab S8 Ultra / Android 12) is on wifi (although I did try connecting to lan while troubleshooting, and the issue remained).

    The tablet connects to the desktop with no problems, and the desktop is extended. There appear to be NO network issues, and no errors during connection. After connecting, I am able to use the extended desktop as normal, moving windows between monitors, maximizing, and getting a good view on the tablet WHILE I AM ACTIVELY WORKING IN WINDOWS DISPLAYED THERE.

    THE PROBLEM:
    The problem presents itself after some idle time. If the view on the tablet (spacedesk client) is static for too long (several minutes), there will be a disconnect/reconnect cycle. The tablet will briefly disconnect, showing a black screen/bouncing text, and then reconnect, showing the extended desktop again. Most of the time, the main Windows desktop is not disturbed – Windows seems to believe that the extended desktop still exists, and it does not try to gather open windows back to active monitors. Sometimes the time between disconnect and reconnect is too long, and the extended desktop flashes (or does the Win 11 zoom in/out thing) and gets disrupted, then resets again on connect. Both scenarios are bad – I don’t want it disconnecting at all, even if it’s idle.

    TROUBLESHOOTING:
    I first tested different network connections, thinking perhaps there were traffic issues, but it persisted across different connection configurations.
    Then I started searching this forum, and found a few threads where the datatronicsoft rep asked whether the person’s screen had been active or idle. These were in older threads, and the rep usually recommended upgrading, but it got me thinking that perhaps screen activity was the issue (or perhaps screen activity, causing network activity, to keep network connections alive).
    There were also references to the “Disconnect Delay” setting in the Driver Console – there is no help for this setting (that I could find in app or docs) so I’m not entirely sure what it means – is it 1) grace period for server to not reset extended desktop when a client temporarily disconnects, because we’re expecting a reconnect, -OR- 2) timeout intended to actually disconnect an idle screen? I think it’s #1, but I would love to get the answer from a rep here. Regardless, I cannot set it to “0” – it just defaults back to “45” when the status is set back to “On”.

    THE WORK-AROUND:
    I opened my NVIDIA control panel and went to the first item in the menu, which is “Adjust image settings with preview”. This has a constantly-rotating generated 3D image (the NVIDIA logo) so that you can see anticipated quality changes as you change settings. I made the window as small as possible while still displaying the rotating image, and put that window on my spacedesk extended monitor (the tablet). I have attached an image of the window here.

    After doing this, NO DISCONNECTS ALL DAY, regardless of whether any other data was static / idle on the screen.

    I don’t think the NVIDIA window is necessary – but I do think some portion of the screen that is constantly updating is required for the work-around. Something that displays a small animated GIF might do the trick.

    It is interesting to note that, since I have the clock displayed at the bottom of every monitor on the taskbar, that at least SOME pixels are getting updated every minute. But this doesn’t appear to be enough.

    THE REQUEST:
    I’m hoping someone from datatronicsoft can chime in on this, and:
    1. Answer the question on the exact operation of the “Disconnect Delay” setting, and
    2. I would request a “keep-alive” feature be added to either keep a little more traffic going between the client and server (if network port timeouts are the root cause) and/or force-redraw the screen or a portion every now and then (if that helps).
    I understand this sort of brute-forces the fix, and it’s not clear to me where in the chain the timeout is occurring – but since this was a question from datasoftinc reps in the past, I assume it is a know potential issue, and you may have more insight into root cause. If the fix is elusive, you could at least have a keep-alive feature for current users until a more nuanced fix was available.

    Thank you again for all of the work on this, and I’m looking forward to the new upcoming releases and product offerings!

    附加檔案:
    你必須 登入 才能查看附件檔案。
正在檢視 0 篇文章
  • 抱歉,回覆主題必需先登入。